import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+(\\-\\d+){4}\\.google\\w*\\.com";
final String string = "> host 66.249.66.1\n"
+ "1.66.249.66.in-addr.arpa domain name pointer crawl-66-249-66-1.googlebot.com.\n\n"
+ "> host crawl-66-249-66-1.googlebot.com\n"
+ "crawl-66-249-66-1.googlebot.com has address 66.249.66.1\n"
+ " \n\n"
+ "Example 2:\n\n"
+ "> host 66.249.90.77\n"
+ "77.90.249.66.in-addr.arpa domain name pointer rate-limited-proxy-66-249-90-77.google.com.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}