import re
regex = re.compile(r"\S+(\-\d+){4}\.google\w*\.com", flags=re.MULTILINE)
test_str = ("> host 66.249.66.1\n"
"1.66.249.66.in-addr.arpa domain name pointer crawl-66-249-66-1.googlebot.com.\n\n"
"> host crawl-66-249-66-1.googlebot.com\n"
"crawl-66-249-66-1.googlebot.com has address 66.249.66.1\n"
" \n\n"
"Example 2:\n\n"
"> host 66.249.90.77\n"
"77.90.249.66.in-addr.arpa domain name pointer rate-limited-proxy-66-249-90-77.google.com.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")