#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-2][1-9]|3[01])\.(?:0[1-9]|1[12])\.(?:19[2-9]\d|[2-9]\d{3})$"
Local $sString = "13.11.1986" & @CRLF & _
"01.01.1999" & @CRLF & _
"31.12.2020" & @CRLF & _
"15.06.2000" & @CRLF & _
"01.01.1920" & @CRLF & _
"" & @CRLF & _
"31.12.1919" & @CRLF & _
"12.13.1985" & @CRLF & _
"1.1.2005" & @CRLF & _
"1.5.86"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")