import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-2][1-9]|3[01])\\.(?:0[1-9]|1[12])\\.(?:19[2-9]\\d|[2-9]\\d{3})$";
final String string = "13.11.1986\n"
+ "01.01.1999\n"
+ "31.12.2020\n"
+ "15.06.2000\n"
+ "01.01.1920\n\n"
+ "31.12.1919\n"
+ "12.13.1985\n"
+ "1.1.2005\n"
+ "1.5.86";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}