re = /^(?:[0-2][1-9]|3[01])\.(?:0[1-9]|1[12])\.(?:19[2-9]\d|[2-9]\d{3})$/m
str = '13.11.1986
01.01.1999
31.12.2020
15.06.2000
01.01.1920
31.12.1919
12.13.1985
1.1.2005
1.5.86'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end