using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\w*prov)\w*rov\w*\b";
string input = @"CreateRov
rov
prov
rover
drove
peoplerover
getProv
aaaprov
aprov
aaarovaaa
arovaaprova";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}