$re = '/\b(?!\w*prov)\w*rov\w*\b/i';
$str = 'CreateRov
rov
prov
rover
drove
peoplerover
getProv
aaaprov
aprov
aaarovaaa
arovaaprova';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);