import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\w*prov)\\w*rov\\w*\\b";
final String string = "CreateRov\n"
+ "rov\n"
+ "prov\n"
+ "rover\n"
+ "drove\n"
+ "peoplerover\n"
+ "getProv\n"
+ "aaaprov\n"
+ "aprov\n"
+ "aaarovaaa\n"
+ "arovaaprova";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}