#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![:\d])([01]\d|2[0-3])(:[0-5]\d){1,2}(?![:\d])"
Local $sString = "Исходный текст 1: В эту субботу в 15:00:23 состоится. В 27:68:01 она уже точно кончится." & @CRLF & _
"Измененный текст 1: В эту субботу в (TBD) состоится. В 27:68:01 она уже точно кончится." & @CRLF & _
"" & @CRLF & _
"Исходный текст 2: Я буду дома примерно в 17:10." & @CRLF & _
"Измененный текст 2: Я буду дома примерно в (TBD)." & @CRLF & _
"" & @CRLF & _
"Исходный текст 3: Рейс перенесли с 16:30 на 18:00." & @CRLF & _
"Измененный текст 3: Рейс перенесли с (TBD) на (TBD)." & @CRLF & _
"" & @CRLF & _
"Исходный текст 4: Мой часы показывают, что сейчас 14:30:10." & @CRLF & _
"Измененный текст 4: Мой часы показывают, что сейчас (TBD)." & @CRLF & _
"" & @CRLF & _
"Исходный текст 5: Встреча состоится 03.10 ровно в 13:00." & @CRLF & _
"Измененный текст 5: Встреча состоится 03.10 ровно в (TBD)." & @CRLF & _
"" & @CRLF & _
"Исходный текст 6: Я уйду через часа 2, у меня поезд в 19:20." & @CRLF & _
"Измененный текст 6: Я уйду через часа 2, у меня поезд в (TBD)." & @CRLF & _
"" & @CRLF & _
"Исходный текст 7: 23:45:54 - работает" & @CRLF & _
"Измененный текст 7: (TBD) - работает" & @CRLF & _
"" & @CRLF & _
"Исходный текст 8: 14:47:70 - не работает" & @CRLF & _
"Измененный текст 8: (TBD):70 - не работает" & @CRLF & _
"" & @CRLF & _
"Как видите, во всех примерах, кроме последнего, время заменилось правильно. То есть, замена работает корректно во всех случаях, кроме тех, когда часы/минуты заданы "правильно", а секунды нет. Как изменить регулярное выражение, чтобы замена работала корректно и в последнем примере?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")