using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![:\d])([01]\d|2[0-3])(:[0-5]\d){1,2}(?![:\d])";
string input = @"Исходный текст 1: В эту субботу в 15:00:23 состоится. В 27:68:01 она уже точно кончится.
Измененный текст 1: В эту субботу в (TBD) состоится. В 27:68:01 она уже точно кончится.
Исходный текст 2: Я буду дома примерно в 17:10.
Измененный текст 2: Я буду дома примерно в (TBD).
Исходный текст 3: Рейс перенесли с 16:30 на 18:00.
Измененный текст 3: Рейс перенесли с (TBD) на (TBD).
Исходный текст 4: Мой часы показывают, что сейчас 14:30:10.
Измененный текст 4: Мой часы показывают, что сейчас (TBD).
Исходный текст 5: Встреча состоится 03.10 ровно в 13:00.
Измененный текст 5: Встреча состоится 03.10 ровно в (TBD).
Исходный текст 6: Я уйду через часа 2, у меня поезд в 19:20.
Измененный текст 6: Я уйду через часа 2, у меня поезд в (TBD).
Исходный текст 7: 23:45:54 - работает
Измененный текст 7: (TBD) - работает
Исходный текст 8: 14:47:70 - не работает
Измененный текст 8: (TBD):70 - не работает
Как видите, во всех примерах, кроме последнего, время заменилось правильно. То есть, замена работает корректно во всех случаях, кроме тех, когда часы/минуты заданы ""правильно"", а секунды нет. Как изменить регулярное выражение, чтобы замена работала корректно и в последнем примере?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}