import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![:\\d])([01]\\d|2[0-3])(:[0-5]\\d){1,2}(?![:\\d])";
final String string = "Исходный текст 1: В эту субботу в 15:00:23 состоится. В 27:68:01 она уже точно кончится.\n"
+ "Измененный текст 1: В эту субботу в (TBD) состоится. В 27:68:01 она уже точно кончится.\n\n"
+ "Исходный текст 2: Я буду дома примерно в 17:10.\n"
+ "Измененный текст 2: Я буду дома примерно в (TBD).\n\n"
+ "Исходный текст 3: Рейс перенесли с 16:30 на 18:00.\n"
+ "Измененный текст 3: Рейс перенесли с (TBD) на (TBD).\n\n"
+ "Исходный текст 4: Мой часы показывают, что сейчас 14:30:10.\n"
+ "Измененный текст 4: Мой часы показывают, что сейчас (TBD).\n\n"
+ "Исходный текст 5: Встреча состоится 03.10 ровно в 13:00.\n"
+ "Измененный текст 5: Встреча состоится 03.10 ровно в (TBD).\n\n"
+ "Исходный текст 6: Я уйду через часа 2, у меня поезд в 19:20.\n"
+ "Измененный текст 6: Я уйду через часа 2, у меня поезд в (TBD).\n\n"
+ "Исходный текст 7: 23:45:54 - работает\n"
+ "Измененный текст 7: (TBD) - работает\n\n"
+ "Исходный текст 8: 14:47:70 - не работает\n"
+ "Измененный текст 8: (TBD):70 - не работает\n\n"
+ "Как видите, во всех примерах, кроме последнего, время заменилось правильно. То есть, замена работает корректно во всех случаях, кроме тех, когда часы/минуты заданы \"правильно\", а секунды нет. Как изменить регулярное выражение, чтобы замена работала корректно и в последнем примере?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}