import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=.{6}\\b)(?<identifier>37|47|[1234])\\d+";
final String string = "234556 <-- single match [2]\n"
+ "012345 <-- no match [0]\n"
+ "346980 <-- single match [3]\n"
+ "379456 <-- double match [37]\n"
+ "435794 <-- single match [4]\n"
+ "471234 <-- double match [47]\n"
+ "171234 <-- single match [1] not double match [17]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}