re = /\b(?=.{6}\b)(?<identifier>37|47|[1234])\d+/m
str = '234556 <-- single match [2]
012345 <-- no match [0]
346980 <-- single match [3]
379456 <-- double match [37]
435794 <-- single match [4]
471234 <-- double match [47]
171234 <-- single match [1] not double match [17]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end