$re = '/^(?=[a-z0-9]{2,5}$)(?=.*[a-z])(?=.*[0-9])(?!(?:.*[a-z]){4})[a-z0-9]+$/m';
$str = '4dse4
d4
4d
34d
34d4
34dd
d44d
dd5d
44
dd
222
2222
ddd
dddd
4dse434353353
ddddd
44444
dddd4
dd4df';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);