import re
regex = re.compile(r"^(?=[a-z0-9]{2,5}$)(?=.*[a-z])(?=.*[0-9])(?!(?:.*[a-z]){4})[a-z0-9]+$", flags=re.MULTILINE)
test_str = ("4dse4\n"
"d4\n"
"4d\n"
"34d\n"
"34d4\n"
"34dd\n"
"d44d\n"
"dd5d\n\n\n\n"
"44\n"
"dd\n"
"222\n"
"2222\n"
"ddd\n"
"dddd\n"
"4dse434353353\n"
"ddddd\n"
"44444\n"
"dddd4\n"
"dd4df")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")