package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"\w+"`)
var str = `"play a constructive and positive role" and "active and hectic reception" and a "[term]" "term"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}