re = /"\w+"/
str = '"play a constructive and positive role" and "active and hectic reception" and a "[term]" "term"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end