using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Amount:)\d+";
string input = @"Date:21 Month:03 Year:2017 Amount:50 Category:Grocery Account:bank Note:expensive";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}