$re = '/(?<=Amount:)\d+/';
$str = 'Date:21 Month:03 Year:2017 Amount:50 Category:Grocery Account:bank Note:expensive';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);