re = /(?<=Amount:)\d+/
str = 'Date:21 Month:03 Year:2017 Amount:50 Category:Grocery Account:bank Note:expensive'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end