using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*[^\d\s])(?:[^\S\r\n]+(\d+))?[^\S\r\n]*$";
string input = @"Battery Bank 1
Dummy 32 Segment 1
System
Modbus 192.168.0.1 Group
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}