use strict;
my $str = 'Battery Bank 1
Dummy 32 Segment 1
System
Modbus 192.168.0.1 Group
';
my $regex = qr/^(.*[^\d\s])(?:[^\S\r\n]+(\d+))?[^\S\r\n]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}