re = /^(.*[^\d\s])(?:[^\S\r\n]+(\d+))?[^\S\r\n]*$/m
str = 'Battery Bank 1
Dummy 32 Segment 1
System
Modbus 192.168.0.1 Group
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end