#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bStandard Deviation:\h+\K\d[\d.]*"
Local $sString = " Format: JPEG (Joint Photographic Experts Group JFIF format)" & @CRLF & _
" Geometry: 934x1189" & @CRLF & _
" Class: DirectClass" & @CRLF & _
" Type: true color" & @CRLF & _
" Depth: 8 bits-per-pixel component" & @CRLF & _
" Channel Depths:" & @CRLF & _
" Red: 8 bits" & @CRLF & _
" Green: 8 bits" & @CRLF & _
" Blue: 8 bits" & @CRLF & _
" Channel Statistics:" & @CRLF & _
" Red:" & @CRLF & _
" Minimum: 3855.00 (0.0588)" & @CRLF & _
" Maximum: 65535.00 (1.0000)" & @CRLF & _
" Mean: 44325.84 (0.6764)" & @CRLF & _
" Standard Deviation: 8571.68 (0.1308)" & @CRLF & _
" Green:" & @CRLF & _
" Minimum: 0.00 (0.0000)" & @CRLF & _
" Maximum: 65021.00 (0.9922)" & @CRLF & _
" Mean: 38079.03 (0.5810)" & @CRLF & _
" Standard Deviation: 8109.29 (0.1237)" & @CRLF & _
" Blue:" & @CRLF & _
" Minimum: 0.00 (0.0000)" & @CRLF & _
" Maximum: 61423.00 (0.9373)" & @CRLF & _
" Mean: 31937.17 (0.4873)" & @CRLF & _
" Standard Deviation: 8422.80 (0.1285)" & @CRLF & _
" Resolution: 72x72 pixels/inch" & @CRLF & _
" Filesize: 101.3Ki" & @CRLF & _
" Interlace: No" & @CRLF & _
" Orientation: Unknown" & @CRLF & _
" Background Color: white" & @CRLF & _
" Border Color: #DFDFDF" & @CRLF & _
" Matte Color: #BDBDBD" & @CRLF & _
" Page geometry: 934x1189+0+0" & @CRLF & _
" Compose: Over" & @CRLF & _
" Dispose: Undefined" & @CRLF & _
" Iterations: 0" & @CRLF & _
" Compression: JPEG" & @CRLF & _
" JPEG-Quality: 70" & @CRLF & _
" JPEG-Colorspace: 2" & @CRLF & _
" JPEG-Colorspace-Name: RGB" & @CRLF & _
" JPEG-Sampling-factors: 2x2,1x1,1x1" & @CRLF & _
" Signature: 68c70dc2aacc49610538d037e7913f66945d7655bb4acc83fa5e13c3581016a9" & @CRLF & _
" Profile-color: 456 bytes" & @CRLF & _
" Tainted: False" & @CRLF & _
" Elapsed Time: 0m:0.006050s" & @CRLF & _
" Pixels Per Second: 175.0Mi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")