use strict;
my $str = ' Format: JPEG (Joint Photographic Experts Group JFIF format)
Geometry: 934x1189
Class: DirectClass
Type: true color
Depth: 8 bits-per-pixel component
Channel Depths:
Red: 8 bits
Green: 8 bits
Blue: 8 bits
Channel Statistics:
Red:
Minimum: 3855.00 (0.0588)
Maximum: 65535.00 (1.0000)
Mean: 44325.84 (0.6764)
Standard Deviation: 8571.68 (0.1308)
Green:
Minimum: 0.00 (0.0000)
Maximum: 65021.00 (0.9922)
Mean: 38079.03 (0.5810)
Standard Deviation: 8109.29 (0.1237)
Blue:
Minimum: 0.00 (0.0000)
Maximum: 61423.00 (0.9373)
Mean: 31937.17 (0.4873)
Standard Deviation: 8422.80 (0.1285)
Resolution: 72x72 pixels/inch
Filesize: 101.3Ki
Interlace: No
Orientation: Unknown
Background Color: white
Border Color: #DFDFDF
Matte Color: #BDBDBD
Page geometry: 934x1189+0+0
Compose: Over
Dispose: Undefined
Iterations: 0
Compression: JPEG
JPEG-Quality: 70
JPEG-Colorspace: 2
JPEG-Colorspace-Name: RGB
JPEG-Sampling-factors: 2x2,1x1,1x1
Signature: 68c70dc2aacc49610538d037e7913f66945d7655bb4acc83fa5e13c3581016a9
Profile-color: 456 bytes
Tainted: False
Elapsed Time: 0m:0.006050s
Pixels Per Second: 175.0Mi';
my $regex = qr/\bStandard Deviation:\h+\K\d[\d.]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}