const regex = new RegExp('(?=[0-9])(?<=(?!00|11|22|33|44|55|66|77|88|99)[0-9])', 'gm')
const str = `91234 5g5567\\t7₇89^`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}