import re
regex = re.compile(r"(?=[0-9])(?<=(?!00|11|22|33|44|55|66|77|88|99)[0-9])", flags=re.MULTILINE)
test_str = "91234 5g5567\\t7₇89^"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")