re = /(?=[0-9])(?<=(?!00|11|22|33|44|55|66|77|88|99)[0-9])/m
str = '91234 5g5567\\t7₇89^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end