$re = '/Location:(?<Location>[^ ]*)/m';
$str = 'Random text Location:AL432 1)ART: New order ANYTHING Location:B2332 1)ART: Any order Random text ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);