re = /Location:(?<Location>[^ ]*)/m
str = 'Random text Location:AL432 1)ART: New order ANYTHING Location:B2332 1)ART: Any order Random text '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end