// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Location:(?<Location>[^ ]*)").unwrap();
let string = "Random text Location:AL432 1)ART: New order ANYTHING Location:B2332 1)ART: Any order Random text ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}