using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\*)(.+?)(\*)";
string input = @"Lorem *ipsum dolor sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis minima maiores voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}