re = /(\*)(.+?)(\*)/m
str = 'Lorem *ipsum dolor sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis minima maiores voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end