package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\*)(.+?)(\*)`)
var str = `Lorem *ipsum dolor sit amet, consectetur adipisicing elit. Optio repellat ipsa quibusdam ab doloremque accusamus nobis minima maiores voluptas, incidunt rerum alias, aliquam ut minus consequatur odio voluptatibus voluptates exercitationem.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}