using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(.+)(?:\n.*)(?:relatora?|desembargadora?|ju[íi]za?)";
string input = @"2. dispositivo
luiza carla g. godoi
juíza
acordam os magistrados da 2ª turma do
tribunal regional do trabalho da 2ª região em: não
na forma da
do agravo de instrumento,
luiz carlos g. godoi
desembargador
conhecer
fundamentação do voto do relator.
luiz carlos g. godoi
relator
§01918.2007.501.02.01-0 (brl53010)
documento elaborado e assinado em meio digital. validade legal nos termos da lei n. 11.419/2006.(cid:13)
disponibilização e verificação de autenticidade no site www.trtsp.jus.br informando:
codigo do documento = 10017
luiza carla g. godoi
relatora
reclamada da ação trabalhista julgada
procedente em parte, está a agravante legitimada Ã
impugnação.
luiza carla g. godoi
desembargadora
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}