import Foundation
let pattern = #"\b(.+)(?:\n.*)(?:relatora?|desembargadora?|ju[íi]za?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
2. dispositivo
luiza carla g. godoi
juíza
acordam os magistrados da 2ª turma do
tribunal regional do trabalho da 2ª região em: não
na forma da
do agravo de instrumento,
luiz carlos g. godoi
desembargador
conhecer
fundamentação do voto do relator.
luiz carlos g. godoi
relator
§01918.2007.501.02.01-0 (brl53010)
documento elaborado e assinado em meio digital. validade legal nos termos da lei n. 11.419/2006.(cid:13)
disponibilização e verificação de autenticidade no site www.trtsp.jus.br informando:
codigo do documento = 10017
luiza carla g. godoi
relatora
reclamada da ação trabalhista julgada
procedente em parte, está a agravante legitimada Ã
impugnação.
luiza carla g. godoi
desembargadora
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)