// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\[modifier.*").unwrap();
let string = "Palais et bâtiments officiels[modifier | modifier le code]
Lieux de culte renommés[modifier | modifier le code]
Vestiges gallo-romains[modifier | modifier le code]\"";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}