import Foundation
let pattern = #"\s*\[modifier.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Palais et bâtiments officiels[modifier | modifier le code]
Lieux de culte renommés[modifier | modifier le code]
Vestiges gallo-romains[modifier | modifier le code]"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)