package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-zа-яА-ЯёЁ0-9._-]+@[A-Za-zа-яА-ЯёЁ0-9._-]+\.[A-Za-zа-яА-ЯёЁ]{2,4}`)
var str = `mail@сайт.рф`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}