import re
regex = re.compile(r"[A-Za-zа-яА-ЯёЁ0-9._-]+@[A-Za-zа-яА-ЯёЁ0-9._-]+\.[A-Za-zа-яА-ЯёЁ]{2,4}")
test_str = "mail@сайт.рф"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")