re = /[A-Za-zа-яА-ЯёЁ0-9._-]+@[A-Za-zа-яА-ЯёЁ0-9._-]+\.[A-Za-zа-яА-ЯёЁ]{2,4}/
str = 'mail@сайт.рф'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end