import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<a[^>]+>)([\\w &]{1,10})(?=<\\/a>)";
final String string = "<a href=\"https://website.com\">0123456789</a>\n"
+ "<a href=\"https://website.com\">less</a>\n"
+ "<a href=\"https://website.com\">0123456789tooMuch</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}