import re
regex = re.compile(r"(?<=<a[^>]+>)([\w &]{1,10})(?=<\/a>)", flags=re.MULTILINE)
test_str = ("<a href=\"https://website.com\">0123456789</a>\n"
"<a href=\"https://website.com\">less</a>\n"
"<a href=\"https://website.com\">0123456789tooMuch</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")