re = /(?<=<a[^>]+>)([\w &]{1,10})(?=<\/a>)/m
str = '<a href="https://website.com">0123456789</a>
<a href="https://website.com">less</a>
<a href="https://website.com">0123456789tooMuch</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end