$re = '/^\d *- *\d{12}$/m';
$str = '2-000000000000
1-234342324342
1 -234342324342
1- 234342324342
1 - 234342324342';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);