// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d *- *\d{12}$").unwrap();
let string = "2-000000000000
1-234342324342
1 -234342324342
1- 234342324342
1 - 234342324342";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}