re = /^\d *- *\d{12}$/m
str = '2-000000000000
1-234342324342
1 -234342324342
1- 234342324342
1 - 234342324342'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end