package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s*)<unk>\s+`)
var str = `hi how <unk> are you`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}