use strict;
my $str = 'hi how <unk> are you';
my $regex = qr/(\s*)<unk>\s+/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";