const regex = new RegExp('(\\s*)<unk>\\s+', 'gm')
const str = `hi how <unk> are you`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);